Back to overview
Downtime
Increased server errors
Oct 20, 2025 at 07:53am UTC
Resolved
Oct 20, 2025 at 10:20am UTC
We are observing the recovery and functionality should be restored. We will monitor the situation till it is fully resolved upstream.
Affected services
Created
Oct 20, 2025 at 07:53am UTC
The app is unstable due to an outage with one of our service providers.
Affected services