Back to overview
Degraded
Email delivery problems
Feb 24, 2026 at 05:59pm UTC
Resolved
Feb 25, 2026 at 10:39pm UTC
Email delivery to Microsoft emails is fully functional again.
Affected services
Updated
Feb 24, 2026 at 06:52pm UTC
We've identified that the issue is limited to Microsoft email addresses (outlook, hotmail, live).
We're in contact with Microsoft to resolve it.
Affected services
Created
Feb 24, 2026 at 05:59pm UTC
Some emails are experiencing delayed or failed delivery due to an issue with our email provider. We've identified the cause and are in contact with their support team.
Affected services