Back to overview
Degraded

Version history is down

May 15, 2026 at 12:39am UTC
Affected services
Version history

Resolved
May 15, 2026 at 10:06pm UTC

Version history recovered.

Updated
May 15, 2026 at 10:02pm UTC

Version history is degraded.

Updated
May 15, 2026 at 12:47am UTC

Version history recovered.

Created
May 15, 2026 at 12:39am UTC

Version history is degraded.