Back to overview
Degraded

Version history is down

May 24, 2026 at 6:03pm UTC
Affected services
Version history

Resolved
May 24, 2026 at 11:08pm UTC

Version history recovered.

Updated
May 24, 2026 at 7:13pm UTC

Version history is degraded.

Updated
May 24, 2026 at 7:01pm UTC

Version history recovered.

Updated
May 24, 2026 at 6:53pm UTC

Version history is degraded.

Updated
May 24, 2026 at 6:37pm UTC

Version history recovered.

Updated
May 24, 2026 at 6:34pm UTC

Version history is degraded.

Updated
May 24, 2026 at 6:08pm UTC

Version history recovered.

Created
May 24, 2026 at 6:03pm UTC

Version history is degraded.